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Introduction 

“PDF” stands for “Portable Document Format”. It is an open standard 

developed by Adobe, and is designed for print. We prefer PDF format to 

other formats, such as Word or Excel, when creating “electronic paper 

forms” for a few reasons. PDF format: 

• Allows for single file distribution – Unlike a Word document, a 

PDF will look the same everywhere. Unlike a Web page, a PDF can be 

attached to an email and distributed independently. 

• Provides a free, widely-distributed reader – Adobe Reader is 

free and most people already have it available on their computers. 

Other readers also exist, including PDF readers built into browsers.1 

• Gives document access control / print control – It is possible to 

discourage users from editing the content of the document in a PDF 

in ways that are not possible in Word documents. 

• Allows for electronic navigation of all text and headings – 

Word forms must be locked down which limits interaction with text. 

Excel does not provide true headings which limits options for creating 

document structure. 

1 Adobe Reader is the only PDF reading application accessible to screen 
readers and PDFs must be opened in the Adobe Reader desktop application – 
not the browser plugin – for a screen reader to work. 
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PDF Form Design 

We accept that a preference for PDF forms over other types of electronic 

forms may be controversial. We recognize that PDF’s: 

• Have a bad reputation among screen reader users. While PDFs 

can be made very accessible, this often does not happen. Also, many 

users may not know to open the PDF using Adobe Reader2, rather 

than the browser plugin. 

• Are not always appropriate for web presentation. In general, a 

Web page is the most accessible option. 

When creating a PDF form, accessibility concepts should be considered 

throughout the document creation process to achieve a fully accessible final 

document. This booklet is not a comprehensive resource on making PDF 

documents accessible. For more information about making accessible PDF 

documents, refer to Create and verify PDF accessibility (Acrobat Pro)3 or 

Acrobat Pro DC Accessible Forms and Interactive Documents4. 

2 The Set PDFs to Open in Acrobat Pro or Reader section in this document 

gives you the steps to set the defaults on your computer. 

3 https://helpx.adobe.com/acrobat/using/create-verify-pdf-

accessibility.html#make_PDFs_accessible 

4 https://www.adobe.com/accessibility/products/acrobat/creating-accessible-

forms.html 
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Planning Your Form: Formatting the Source 

Document 

Certain steps must be taken in the source document prior to conversion to 

PDF because of Acrobat’s restricted word processor options and limited 

layout functions. We use Microsoft Word to create most of our form source 

documents. Though there are other programs you can use to design forms, 

such as InDesign or LiveCycle, Microsoft Word is readily available and 

familiar to almost everyone. 

The items in this section are best finalized now to save you time later. You 

don’t want to discover any errors after you’ve got the whole document 

tagged. When that happens, you have to essentially start over and all that 

time is lost. 

Content 

Ensure the content of the source document: 

• Asks only for the information you absolutely need. In the words of 

UI/UX Designer, Ken Lee-Sanekata, “Take away as many form fields 

as possible, until you can’t, and then you try some more.” Really 

consider how the form is used and what its purpose is before 

committing to 50 form fields when 10 would do the job. 

• Is written in plain language. This applies to all text in the form: 

questions, labels, and instructions. Exceptions to this would be forms 

that have a niche audience, though we caution you to not use that as 

an excuse to write clearly. Even forms with very specific user groups 

have new people join those groups. The clearer the form’s language, 

the fewer questions you will get on the back end. 
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• Has good flow. Information and form fields should appear in a logical 

order that does not jump around. For example, instructions typically 

appear before a user is supposed to act; they are of little help after 

someone has already filled out a field. Address options generally 

appear in order of street, city, state, zip. Putting information out of 

order increases cognitive load. If there is no logical order to a 

selection of items, use alphabetical order. 

• Has clear instructions. When filling out a form, users should be 

clearly told what is expected. This includes small instructions like 

“select one,” “select all that apply,” “fields with an asterisk are 

required,” or “(optional).” This also means labeling form fields with 

required formats, such as “Phone number: (xxx) xxx-xxxx,” if you 

choose to use them. 

• Has document information in the header or footer on each page, such 

as “Form xyz, page 2.” The format of this information is at your 

discretion, though if a form has two names, then both names should 

appear at the top of the first page, then you can use the abbreviated 

name in the header or footer. 

• Uses form fields for their intended function: 

o Text fields are used where the field entry can vary widely. 

Examples include names, addresses and descriptions or 

explanations. Ensure the field is large enough to contain the 

desired entry. 

o Check boxes are used where there are a set number of 

selections and more than one may be selected at a time. If 

“select all that apply” is applicable to that section, check boxes 

should be used. The default size of checkboxes is somewhat 

large, so you may want to resize it. 

Texas Workforce Commission 4 



 

  

   

   

  

  

 

  

  

   

 

 

 

  

 

 

 

 

     

    

   

  

   

  

 

  

   

PDF Form Design 

o Radio buttons are used when there is a set number of 

selections, but only one may be selected. If “select only one” or 

yes/no is applicable to that section, radio buttons should be 

used. If there are more than a handful of selections, use a 

dropdown list to save space on the form. The default size of 

radio buttons is somewhat large, so you may want to resize it. 

o Dropdown lists are used when there are a set number of 

selections, but only one may be selected. Ensure the field is wide 

enough to show the text of the widest selection. 

Font Selection and Size 

Ensure the font selections and sizes in the source document are readable. 

We recommend using 12-point Verdana for most content, though many 

other fonts are considered accessible. Headings should use bigger, bolder 

choices to make them stand out. 

Layout 

Ensure the source document’s layout: 

• Is intuitive to use. Typically, that means that information reads from 

left to right, top to bottom. 

• Groups form fields according to function or type. 

• Has consistently placed form field labels. When possible, select a 

placement and stick to it, whether it be all form labels above the 

fields or generally to the left. Exceptions are check box and radio 

button options which typically fall to the right of the field. 

• Uses headings to provide users with a meaningful sequence of 

information and make the document easier to navigate. Headings are 
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set with Heading styles 1 through 9 in Word, though Acrobat only 

goes up to heading level 6. 

• Has adequate text spacing: 

o We recommend at least 1.15 line spacing within paragraphs. 

o We recommend a minimum of 16-point After paragraph 

spacing for a 12-point font. 

o We recommend a minimum of .02 top, bottom, left, and right 

spacing around text inside of tables. 

• Has adequate space to contain all the answers expected for each 

form field and prevent scrolling. This is especially important for forms 

that will be printed. Acrobat does not have expanding form fields like 

Word does. To save yourself time, test this in the source document 

prior to converting to PDF. We recommend a minimum of: 

o 35 characters each for first and last name or the equivalent 

(71) for a full name field. 

o 40 characters for address lines and city names. 

o 2 characters for a state abbreviation and skipping the state list 

dropdown. 

o 9 characters for a zip code. 

o 40 characters for an email address. 

The flip side to this is not giving too much space for the size of the 

expected input. You don’t want a 40-character form field to hold 

something that’s a set number of characters like a date. 

Texas Workforce Commission 6 
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Using Tables for Layout 

The best way to create a paper form that has a consistent and logical layout 

and that flows predictably is to use a layout table. The table will be removed 

after conversion to PDF so typical table concerns are not an issue. 

Following are tips for formatting a layout table in Word: 

• Adjust table width in Table Properties or on the ruler in the 

document view. 

• Use borders to distinguish table cells. Select the table, go to the 

Table Tools area of the Ribbon, choose the Design tab and click on 

Borders. 

• If your entire form is a table, use the top row of the table for the 

logo, form title, and other information, such as the date. If you are 

using paragraphs for the document title and instructions, use the top 

row for the first table section heading. 

• Use section headings to change subject content, group like form 

fields, and to help a low-vision user quickly find a particular section. 

• Use merged cells to keep like information together. 

• Use split cells to separate. 

• Use blank spaces to get the exact layout you want. It’s visually 

pleasing when similar items line up both vertically and horizontally, if 

possible. 
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Figure 1 – Example Form Using a Table for Layout 
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Color 

Though it is important to avoid the use of color alone to convey information, 

color is a great way to help sighted users navigate a form. It can be used to 

make headings and instructions stand out. Using color wisely can also give 

your form a more finished look. 

Figure 2 – Form Before and After Showing Use of Color 

When selecting colors to use in your forms, verify sufficient color contrast 

ratios, so it is easy to discern text from background. We recommend 

downloading the Color Contrast Analyser tool and using it to verify adequate 

contrast ratio of 4.5:1 (Figure 3, item 1). 
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Figure 3 – Colour Contrast Analyser Results 

Convert from Word to PDF 

It’s worth noting that even if your source document is fully accessible, it 

won’t always convert as intended, so some items may need tweaking 

anyway. Follow the steps below to convert your source document to PDF. 

1. Go to File > Save As. 

2. In the middle top of the window, you’ll see a place to put the file 

name. Under that is a dropdown (Figure 4, item 1) to select the file 

format. Select PDF (Figure 4, item 2) from the dropdown. 
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Figure 4 – Save As Window 

3. Select the Save button (Figure 4, item 3). 

4. A tagged PDF version of your document will open in a new window. If 

it does not automatically open, navigate to the location where you 

saved the document and open it. 

Texas Workforce Commission 11 
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Formatting the PDF 

This section applies to all PDF forms, whether they were converted from 

accessible source documents or were already PDFs. The following tasks will 

be performed (or at least verified) in the PDF. 

If you are unfamiliar with using Acrobat Pro, the Acrobat User Guide 

workspace basics page5 will help. 

PDF forms start off a bit differently than the average PDF document. Prior to 

adding form fields, it is best to delete the tags from the document. Then, 

after your form fields are added, you can add all the tags at once and 

everything will be in the correct order. If you edit the original tags, then tag 

the form fields, all the of your work will be overwritten. 

To begin creation of a PDF form: 

1. delete the existing tags, 

2. add the form fields, 

3. set and verify form field properties, then 

4. add tags to the document. 

The steps to do all the above tasks can be found in the sections below. 

5 https://helpx.adobe.com/acrobat/using/workspace-basics.html 
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Delete the Existing Tags 

1. In the Tags pane, right click on Tags (Figure 5, item 1) and select 

Delete Tag (Figure 5, item 2) from the resulting dropdown. 

Figure 5 – Deleting Empty Tags from the Tags Pane 

2. The pane will now say No Tags Available (Figure 6). 
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Figure 6 – No Tags Available in Tags Pane 
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Add the Form Fields 

1. In the right pane, select Prepare Form. The Prepare Form screen 

will appear. Note: If Prepare Form is not in the right pane, go to 

Tools, then select Add under the Prepare Form icon. 

2. Select the document you want to add form fields to then select 

Start. 

3. Acrobat will add form fields based on the layout of the document. 

Form fields will not always be where you want them. There may be 

extra fields or missing fields. 

• To delete an extra field, right click on the field and select Delete 

from the resulting menu. We recommend deleting extra fields 

first, so that you don’t accidentally waste time formatting a field 

you don’t need. 

• To add a missing form field, select the type of field you want 

from the Prepare Form ribbon (Figure 7) at the top of the screen 

then click on the place in the document where you want the field 

to appear. Common field selections are: 

o Text field (Figure 7, item 1) 

o Check box (Figure 7, item 2) 

o Radio button (Figure 7, item 3). Radio buttons work as a 

group. All radio buttons with the same name are one group. 

o Dropdown list (Figure 7, item 4) 
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Figure 7 – Prepare Form Ribbon Showing Form Field Icons 

Time saving tip: Add all of your text fields first, then use the tips in 

the next section to set all the properties for these fields. After all like 

properties are set, go back and add in check boxes, radio buttons, or 

dropdown lists and format as needed. 

4. Check the order of the form fields in the Fields pane of the Prepare 

Forms tool. Drag any out of order fields to the correct place. 

Set/Verify Form Field Properties 

At a minimum, every form field must have a tooltip set for it in the 

properties. Acrobat will automatically set the tooltip based on the label next 

to the field, but we still recommend verifying the correctness of the 

properties of each one. 

To set the properties: 

1. Double click on the desired form field to open the Properties window 

(Figure 8). The name of the window will change depending on the 

type of form field. The example below shows properties for a text 

field, so the window is named Text Field Properties. 
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Figure 8 – Text Field Properties Window, General Tab 

2. On the General tab, ensure the Tooltip (Figure 8, item 1) field 

correctly reflects the label on the form. Optionally: 

a. Set the form field to Read Only (Figure 8, item 2). We often do 

this for the signature fields of forms that are signed physically 

then say something like “Signature, print and sign form” in the 

tooltip. 

b. Set the form field as Required (Figure 8, item 3). Note that this 

setting will make the boxes around these fields red while you are 

in Prepare Form mode. 
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3. On the Appearance tab (Figure 9), set the font that responses will 

appear in. We do not recommend using the Auto font size, as this 

allows the text to shrink to a point where it is unreadable. We 

recommend 12-point Verdana (Figure 9, items 1 and 2). 

Figure 9 – Text Field Properties Window, Appearance Tab 

4. On the Options tab, set how you want the field to handle text. 
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Figure 10 – Text Field Properties Window, Options Tab 

a. Leave the alignment (Figure 10, item 1) Left if the form field 

entry will be text. Set the alignment Right if the form field entry 

will be numerical. 

b. Leave Check spelling (Figure 10, item 2) checked so that those 

filling out the form will know when they have made a spelling 

error. 
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c. Select Multi-line (Figure  10, item 3) if the field is supposed to 

receive a multiple line answer. Be sure the input field has 

enough space to allow multiple lines of input. Do not select this if 

the field allows room for one line of an answer. 

d. Select Scroll long text (Figure  10, item 4) if you wish to allow 

the user to enter more text than will fit in the input field and the 

form will be used electronically. If the form is to be printed, any 

words that scrolled will not show on the printed version. We 

recommend turning this selection off, unless the form will never 

be printed. 

e. Select Limit of [x] characters (Figure  10, item 5) if the field 

input is limited. Optionally, provide the character limit in the 

visual form field label. If Font Size = Auto is selected on the 

Appearance tab, choose a character limit that will prevent the 

font from shrinking to an unreadable size. 

Time saving tip: Once the Properties window is open, you can leave 

it up and select other form fields to view their properties. This saves 

you many clicks along the way. 

Another time saving tip: For form fields that have similar properties, 

such as those on the Appearance and Options tabs, you can select 

more than one form field and set the properties for all of them at 

once. 

We rarely use options on the Format tab on fields that hold items such as 

dates or phone numbers. If you choose to limit the format of form entries, 

you should let users know by providing that information both visually (in the 

source document prior to converting) and in the tooltip of the field. An 

example would be a tooltip that says “Date signed: 2 digit day/2 digit 

month/2 digit year” or “Date signed: dd/mm/yy” with a label such as “Date 

signed: (dd/mm/yy).” 
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Add Tags to the Document 

After all form fields have been created, you will add the accessibility tags 

back to the document. Be sure you are happy with all form field 

configurations before proceeding, since going back to correct them after the 

tags are created can sometimes have unpredictable results. 

In the Tags pane, right click on No Tags available (Figure 11, item 1) and 

select Add Tags to Document (Figure 11, item 2) from the resulting menu. 

Tags will appear in the Tags pane. 

Figure 11 – Add Tags to Document 
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Tags not only set the order the document is navigated in, they determine 

how content is read by screen readers. It is imperative that the tags in your 

document correctly reflect the function a given item (text, image, table, etc.) 

has and that the tags are in the correct order. 

Run the Accessibility Full Check 

The Accessibility Full Check is a tool you can use to ensure you didn’t miss 

any key accessibility aspects. It will not catch everything in the document, 

which is why we encourage you to learn and apply all the accessibility 

concepts prior to running the check. However, it is a nice addition to the 

accessibility process and we encourage you to run it on all your documents. 

To run the Accessibility Full Check: 

1. Select Accessibility in the right pane. The selections in the right 

pane will change. Note: If Accessibility does not appear in the right 

pane, go to Tools then select Open under the Accessibility icon. 

2. Select Full Check. The Accessibility Checker Options window 

appears. 

3. You don’t need to change anything in the window. Select Start 

Checking. Depending on how large your document is, the check may 

take a minute. 

4. Results will appear in the left pane (Figure  12). Anything that is in 

bold is an issue. The number beside the item is the number of issues 

found. If you have done everything in this manual, you should only 

have two issues in bold. 
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Figure 12 – Accessibility Checker Results in the Left Pane 

Two issues will always be bold in the checker results: Document > 

Logical reading order and Document > Color contrast. Both of these 

must be checked manually. Once you have checked them, right click 

on each and select Pass. 

5. Use the expander beside each bold issue to expand view each item. 

You may need to expand more than once (such as Alternate Text > 

Figures alternate text – failed to see the list of figures without alt 

text). 
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Figure 13– Accessibility Checker Results Expanded 

6. Once you get down to the root list of issues (the bolded items do not 

have expanders), you can right click on each for guidance on how to 

fix it. For simple things like alt text and document title (often referred 

to in class as document properties), select Fix and a window will 

open for you to edit those items. For more complex issues such as 

table headers, you can select Show in Tags panel and follow the 

instructions in previous sections here to fix the issue. 
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7. When you feel each of your issues are fixed, right click on each and 

select Check Again. You should complete the document with no 

issues showing in the check. 

Perform Manual Accessibility Tests 

Even when you follow all of the accessibility rules, things can still be wrong 

in the document. It’s a good idea to do a quick manual test of each form 

prior to calling it final. 

Keyboard 

Keyboard accessibility is one of the most important aspects of accessibility. 

Many users with motor impairment rely on keyboards to navigate 

documents. A few common keys, such as Tab, arrows, Enter, and Space Bar, 

are used to perform keyboard testing. 

Generally, you can just tab through the document to navigate through all 

the links and form fields. 

• Tab to links and press Enter to open them. 

• Tab to form fields, then: 

o Type directly into text fields. 

o Use the arrow keys to navigate through dropdown selections or 

Alt + Down Arrow to expand dropdown lists. 

o Use the arrow keys to navigate between radio button choices. 
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Refer to Keys for navigating a PDF6 if you’d like more information about 

keyboard use. 

Screen Reader 

Testing PDFs with JAWS is not generally required. As long as you’ve taken all 

the steps outlined in this guide to make the PDF accessible, you can usually 

feel comfortable that the document is accessible. However, if you have 

access to JAWS, it’s a good idea to go ahead and give the PDF a final check 

with JAWS and make sure everything behaves as expected. JAWS will 

automatically read an entire document if you open JAWS then open the 

document. This is the easiest way to test. If the document is not read 

automatically, press Insert + Down Arrow. 

You will also want to confirm the labels for all form fields are announced 

properly by JAWS when you use the Tab key to move from field to field. 

Refer to Accessing PDF Documents with Assistive Technology7 for more tips 

and keystrokes. 

Change Reading Options for Large Files 

When reading large PDF files, JAWS will sometimes act in unexpected ways. 

Depending on your PDF settings, JAWS might only read a single page at a 

time. When this happens, you will not be able to use some JAWS features 

effectively. For example, you cannot use JAWS heading navigation to move 

through the document, since JAWS is only looking at one page at a time. Or, 

if a list or a data table spans more than one page, you may not be able to 

use the JAWS list or table navigation features as you would expect. 

6 https://helpx.adobe.com/acrobat/using/keyboard-shortcuts.html#keys_for_navigating 

_a_pdf 
7 https://www.adobe.com/content/dam/acom/en/accessibility/pdfs/accessing-pdf-sr.pdf 
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To avoid these issues, you will want to configure your PDF software – either 

Acrobat Reader or Acrobat Pro – to read the entire document instead of only 

the currently visible pages. 

The Downside 

If you set your Acrobat software to read the entire document, it may take 

longer for JAWS to process it. For very large documents, this may take 

several seconds or even a minute. 

In those cases, you might want to reset your configuration to read only the 

visible pages. If the PDF file is well structured, you may be able to use the 

PDF bookmarks to navigate the document rather than depending on the 

headings. 

Configure Acrobat Reader DC (Simple Method) 

Below are the steps to set Acrobat Reader DC to read the entire document: 

1. Open a PDF in Acrobat Reader DC. 

2. Go to Edit > Accessibility > Change Reading Options. 

3. In the Change Reading Options of Current Document dialog, select 

the Read the entire document radio button. 

4. Press Enter to save the changes. 
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Configure Acrobat Reader or Pro DC (Advanced) 

Below is a more advanced way to configure the Read the entire document 

option. This method works for both Acrobat Reader and Acrobat Pro DC. 

1. Open a PDF in Acrobat Reader DC or Adobe Acrobat Pro DC. 

2. Press Control + K or go to Edit > Preferences to open the 

Preferences dialog. 

3. In the Categories list, select Reading. 

4. Tab to the Page vs Document combo box, found in the Screen 

Reader Options section. 

5. Select Read the entire document in the combo box. 

6. Tab to the OK button, and select Enter to save the changes. 

Configure Acrobat Reader or Pro DC (Even More Advanced) 

You may have noticed another option in the Page vs Document combo box 

called For large documents, only read the currently visible pages. This 

option gives you a little more control over when JAWS will process the entire 

document and when it will read only the current visible pages. 

If you select the For large documents, only read the currently visible 

pages option, you will also need to set the option called Minimum number 

of pages in a large document. Once you set both of those options, JAWS 

will only process the entire document if it is less than the number you 

specified in the Minimum number of pages field. If the number of pages in 

the document exceeds that threshold, JAWS will read only the currently 

visible pages. 
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If you choose this more advanced option, you must remain aware that some 

documents will act differently than others. The most noticeable difference is 

usually that the JAWS heading navigation feature works in some smaller 

documents, but not in larger documents. 

Set PDFs to Open in Acrobat Pro or Reader 

Windows 10 is set by default to open PDFs in Microsoft Edge. Acrobat 

functions do not work correctly in Edge, so we recommend setting your 

computer to open PDFs in Pro or Reader. 

Go to Make Acrobat or Reader the default owner of PDF files on Windows 108 

for the steps to change this setting. 

Change Internet Explorer Settings for PDF 

Files 

We recommend setting your Internet Explorer options to open PDF files in 

Adobe PDF Reader (as opposed to a browser window). To change the default 

behavior in Internet Explorer, you must disable the Adobe PDF Reader add-

on. Follow these steps: 

1. Open Internet Explorer, and choose Tools > Manage Add-ons. 

2. Under Add-on Types, select Toolbars and Extensions (should be 

selected by default). 

3. In the Show dropdown menu, select All Add-ons. 

4. In the list of add-ons, select Adobe PDF Reader. 

8 https://helpx.adobe.com/acrobat/kb/not-default-pdf-owner-windows10.html  
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5. Select the Disable button which turns off the add-on so it does not 

open PDFs in the browser. 

Conclusion 

That’s it in a nutshell. Pretty simple, right? We know, we know; it’s a lot. 

Even though it seems like a lot of information, you will probably still have 

scenarios that fall outside the scope of this document. Feel free to email us9 

with questions. 

9 accessibility@twc.state.tx.us 
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